CVE-2026-92936 vm2 3.11.0 before 3.11.7 Information Disclosure via Error Stack
Sandboxed code can leak absolute host filesystem paths and internal function names via error stack traces, exposing sensitive system information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92936?
CVE-2026-92936 is a medium-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vm2 versions 3.11.0 through 3.11.6 leak absolute host filesystem paths to sandboxed code through error stack formatting. Attacker-supplied code can force the host-realm source transformer to throw a SyntaxError (for example by calling eval with malformed source) and then read the error's .stack property; the bridge forwards the .stack read to the host-realm formatter, bypassing the sandbox-side host-path redaction introduced for GHSA-v27g-jcqj-v8rw. The returned stack string discloses absolute paths from vm2, Node.js internals, and the embedding application's own source tree, along with host function names. Default new VM() and new NodeVM() configurations are affected without any special options, and the issue persists when string eval is disabled because the host-side transformer throws before eval is handled. The impact is information disclosure only; no code execution results. Fixed in vm2 3.11.7.
Weakness: CWE-209
Which versions are affected by CVE-2026-92936?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.11.0 | 3.11.7 |
vm2 npm | From 3.11.0 | 3.11.7 |
How do I fix CVE-2026-92936?
Upgrade vm2 to 3.11.7 or later.
Is CVE-2026-92936 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92936 exists.
Sources
Also known as ECHO-b9fc-a52a-f0b3, GHSA-x6m4-chr9-cg97, MINI-4r2m-h48r-wxx7.