CVE-2026-92937 vm2 3.11.6 Remote Code Execution via Promise call/apply

Critical 10.0 Published Updated

Attackers can escape the vm2 sandbox to execute arbitrary code on the host Node.js process by exploiting incomplete sanitization of Promise rejection handlers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92937?

CVE-2026-92937 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vm2 3.11.6 is vulnerable to a sandbox escape leading to remote code execution in the host Node.js process. The fix for GHSA-m283-3h24-438v is incomplete: the bridge gate at lib/bridge.js:1624 identity-checks only the direct call target when deciding whether to rebuild/sanitise a rejected host Promise value. Registering the rejection handler through Function.prototype.call or .apply indirection (e.g., p.then.call(p, undefined, cb)) makes the intercepted target host Function.prototype.call, so the sanitiser never runs and the raw host error reaches sandbox code with its own properties intact. If an embedder exposes a host-realm Promise to the sandbox (an async host function bridged via the sandbox option, or a NodeVM external module's async method) and that Promise rejects with an Error carrying a non-primitive own property referencing a host object (for example err.detail = process), untrusted code in the sandbox obtains a fully functional proxy to that host object and can execute arbitrary commands with the privileges of the host process (e.g., e.detail.mainModule.require('child_process').execSync(...)). The direct p.then(undefined, cb), bind, and Reflect.apply forms are correctly sanitised. Fixed in vm2 3.11.7.

Weakness: CWE-94

Which versions are affected by CVE-2026-92937?

2 open source packages ship an affected version, including vm2.

PackageAffectedFixed in
vm2 npmFrom 3.11.63.11.7
vm2 npmFrom 3.11.63.11.7

How do I fix CVE-2026-92937?

Upgrade vm2 to 3.11.7 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-92937 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92937 exists.

Sources

Also known as CLEANSTART-2026-UO50229, ECHO-334d-48a7-6e03, GHSA-647f-g98j-qq25, MINI-h654-8g2r-hmwf, ROOT-APP-NPM-CVE-2026-92937.

Is CVE-2026-92937 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free