CVE-2026-92938 vm2 3.11.3 through 3.11.6 Remote Code Execution via node:sqlite
Sandboxed code can execute arbitrary native code on the host by exploiting node:sqlite module exposure in vm2.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92938?
CVE-2026-92938 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
vm2 versions 3.11.3 through 3.11.6 expose Node.js's host node:sqlite module to code running in NodeVM when that builtin is permitted, either explicitly or through builtin: ['*']. The module is wrapped with vm.readonly(), which prevents property assignment but leaves host-authority callables reachable; in addition, the resolver treats any request starting with 'node:' as a core-module request and the runtime strips only one 'node:' prefix, so a sandbox request for 'node:node:sqlite' resolves to the configured node:sqlite entry. Sandboxed code can therefore create an in-memory DatabaseSync with extension loading enabled and call DatabaseSync.loadExtension() on a native library bundled in the untrusted plugin package (path derived from __dirname). SQLite loads the library into the Node.js host process and invokes its native entry point, giving the sandboxed plugin arbitrary native code execution outside the sandbox with the host process's privileges. The issue is fixed in vm2 3.11.7.
Weakness: CWE-693
Which versions are affected by CVE-2026-92938?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.11.3 | 3.11.7 |
vm2 npm | From 3.11.3 | 3.11.7 |
How do I fix CVE-2026-92938?
Upgrade vm2 to 3.11.7 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-92938 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92938 exists.
Sources
Also known as CLEANSTART-2026-SJ12974, ECHO-0ab6-1f5d-9ad5, GHSA-6w8r-xxw2-g3hx, MINI-q5hp-rc22-xq59, ROOT-APP-NPM-CVE-2026-92938.