{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92938 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92938 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92938 and fix it if it is affected.\n\nWhat it is: CVE-2026-92938 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92938 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92938/ (Markdown: https://insights.sbomify.com/CVE-2026-92938/index.md)","id":"CVE-2026-92938","markdown":"https://insights.sbomify.com/CVE-2026-92938/index.md","name":"CVE-2026-92938","record":{"aliases":["CLEANSTART-2026-SJ12974","ECHO-0ab6-1f5d-9ad5","GHSA-6w8r-xxw2-g3hx","MINI-q5hp-rc22-xq59","ROOT-APP-NPM-CVE-2026-92938"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"low_privilege","summary":"Sandboxed code can execute arbitrary native code on the host by exploiting node:sqlite module exposure in vm2.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"vm2 versions 3.11.3 through 3.11.6 expose Node.js's host node:sqlite module to code running in NodeVM when that builtin is permitted, either explicitly or through builtin: ['*']. The module is wrapped with vm.readonly(), which prevents property assignment but leaves host-authority callables reachable; in addition, the resolver treats any request starting with 'node:' as a core-module request and the runtime strips only one 'node:' prefix, so a sandbox request for 'node:node:sqlite' resolves to the configured node:sqlite entry. Sandboxed code can therefore create an in-memory DatabaseSync with extension loading enabled and call DatabaseSync.loadExtension() on a native library bundled in the untrusted plugin package (path derived from __dirname). SQLite loads the library into the Node.js host process and invokes its native entry point, giving the sandboxed plugin arbitrary native code execution outside the sandbox with the host process's privileges. The issue is fixed in vm2 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 3.11.3 through 3.11.6 Remote Code Execution via node:sqlite","id":"CVE-2026-92938","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 3.11.3 through 3.11.6 Native Code Execution via crypto.setEngine","id":"CVE-2026-92939"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-6w8r-xxw2-g3hx"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-6w8r-xxw2-g3hx"}],"prev":{"headline":"vm2 3.11.6 Remote Code Execution via Promise call/apply","id":"CVE-2026-92937"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-19","vendors":["patriksimek"]},"summary":"Sandboxed code can execute arbitrary native code on the host by exploiting node:sqlite module exposure in vm2.","url":"https://insights.sbomify.com/CVE-2026-92938/"}