{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92939 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92939 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92939 and fix it if it is affected.\n\nWhat it is: CVE-2026-92939 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92939 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92939/ (Markdown: https://insights.sbomify.com/CVE-2026-92939/index.md)","id":"CVE-2026-92939","markdown":"https://insights.sbomify.com/CVE-2026-92939/index.md","name":"CVE-2026-92939","record":{"aliases":["CLEANSTART-2026-AL98227","ECHO-30f3-2738-f894","GHSA-46pr-c5wc-xffx","MINI-pc6c-wm4v-9h9v","ROOT-APP-NPM-CVE-2026-92939"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"low_privilege","summary":"Attackers can escape the vm2 sandbox and execute arbitrary native code by abusing the exposed crypto module's setEngine function.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-114","name":"Process Control"}],"description":"vm2 3.11.3 through 3.11.6 exposes the host Node.js crypto module to a NodeVM sandbox when the crypto builtin is allowed. The module is presented via a recursive read-only proxy, but its callable exports still execute with host-process authority. Sandboxed JavaScript can therefore call crypto.setEngine() with a filesystem path to an attacker-supplied native library (for example, one bundled in an untrusted plugin package already written to disk); OpenSSL asks the operating-system dynamic loader to load the file, and the library's constructor executes native code in the host process before engine-symbol validation rejects it. Exploitation requires only the crypto builtin and does not require fs, process, module, child_process, worker_threads, vm, or inspector access, resulting in a sandbox escape and arbitrary native code execution. Fixed in 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 3.11.3 through 3.11.6 Native Code Execution via crypto.setEngine","id":"CVE-2026-92939","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent","id":"CVE-2026-92940"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-46pr-c5wc-xffx"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-46pr-c5wc-xffx"}],"prev":{"headline":"vm2 3.11.3 through 3.11.6 Remote Code Execution via node:sqlite","id":"CVE-2026-92938"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can escape the vm2 sandbox and execute arbitrary native code by abusing the exposed crypto module's setEngine function.","url":"https://insights.sbomify.com/CVE-2026-92939/"}