# CVE-2026-92939: vm2 3.11.3 through 3.11.6 Native Code Execution via crypto.setEngine

> Attackers can escape the vm2 sandbox and execute arbitrary native code by abusing the exposed crypto module's setEngine function.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-AL98227, ECHO-30f3-2738-f894, GHSA-46pr-c5wc-xffx, MINI-pc6c-wm4v-9h9v, ROOT-APP-NPM-CVE-2026-92939

## What is CVE-2026-92939?

CVE-2026-92939 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vm2 3.11.3 through 3.11.6 exposes the host Node.js crypto module to a NodeVM sandbox when the crypto builtin is allowed. The module is presented via a recursive read-only proxy, but its callable exports still execute with host-process authority. Sandboxed JavaScript can therefore call crypto.setEngine() with a filesystem path to an attacker-supplied native library (for example, one bundled in an untrusted plugin package already written to disk); OpenSSL asks the operating-system dynamic loader to load the file, and the library's constructor executes native code in the host process before engine-symbol validation rejects it. Exploitation requires only the crypto builtin and does not require fs, process, module, child_process, worker_threads, vm, or inspector access, resulting in a sandbox escape and arbitrary native code execution. Fixed in 3.11.7.

Weakness: CWE-114 (Process Control)

## Which versions are affected by CVE-2026-92939?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.11.3 | 3.11.7 |
| `vm2` | npm | From 3.11.3 | 3.11.7 |

## How do I fix CVE-2026-92939?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92939 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92939 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92939 and fix it if it is affected.

What it is: CVE-2026-92939 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92939 exists.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92939/ (Markdown: https://insights.sbomify.com/CVE-2026-92939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92939
- OSV: https://osv.dev/vulnerability/CVE-2026-92939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92939/
Summaries are generated and may contain mistakes; the official description above is the record.
