CVE-2026-92940 vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent
Sandboxed code can steal host HTTPS credentials and read response bodies by accessing the global agent, requiring explicit https module allowance.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92940?
CVE-2026-92940 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.
Weakness: CWE-668
Which versions are affected by CVE-2026-92940?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.11.3 | 3.11.7 |
vm2 npm | From 3.11.3 | 3.11.7 |
How do I fix CVE-2026-92940?
Upgrade vm2 to 3.11.7 or later.
Is CVE-2026-92940 being exploited?
There is no known exploitation of CVE-2026-92940 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-JW87371, ECHO-54bb-3d76-70e2, GHSA-h85j-hv3c-qfgq, MINI-3xvm-h9j5-pr25, ROOT-APP-NPM-CVE-2026-92940.