{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"There is no known exploitation of CVE-2026-92940 in the wild and no public exploit code.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92940 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92940 and fix it if it is affected.\n\nWhat it is: CVE-2026-92940 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92940 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92940/ (Markdown: https://insights.sbomify.com/CVE-2026-92940/index.md)","id":"CVE-2026-92940","markdown":"https://insights.sbomify.com/CVE-2026-92940/index.md","name":"CVE-2026-92940","record":{"aliases":["CLEANSTART-2026-JW87371","ECHO-54bb-3d76-70e2","GHSA-h85j-hv3c-qfgq","MINI-3xvm-h9j5-pr25","ROOT-APP-NPM-CVE-2026-92940"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Sandboxed code can steal host HTTPS credentials and read response bodies by accessing the global agent, requiring explicit https module allowance.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L","version":"4.0"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"}],"description":"vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent","id":"CVE-2026-92940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 3.11.3 before 3.11.7 TLS Trust Store Manipulation","id":"CVE-2026-92941"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-h85j-hv3c-qfgq"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-h85j-hv3c-qfgq"}],"prev":{"headline":"vm2 3.11.3 through 3.11.6 Native Code Execution via crypto.setEngine","id":"CVE-2026-92939"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Sandboxed code can steal host HTTPS credentials and read response bodies by accessing the global agent, requiring explicit https module allowance.","url":"https://insights.sbomify.com/CVE-2026-92940/"}