# CVE-2026-92940: vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent

> Sandboxed code can steal host HTTPS credentials and read response bodies by accessing the global agent, requiring explicit https module allowance.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-JW87371, ECHO-54bb-3d76-70e2, GHSA-h85j-hv3c-qfgq, MINI-3xvm-h9j5-pr25, ROOT-APP-NPM-CVE-2026-92940

## What is CVE-2026-92940?

CVE-2026-92940 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-92940?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.11.3 | 3.11.7 |
| `vm2` | npm | From 3.11.3 | 3.11.7 |

## How do I fix CVE-2026-92940?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92940 being exploited?

There is no known exploitation of CVE-2026-92940 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92940 and fix it if it is affected.

What it is: CVE-2026-92940 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92940 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92940/ (Markdown: https://insights.sbomify.com/CVE-2026-92940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92940
- OSV: https://osv.dev/vulnerability/CVE-2026-92940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92940/
Summaries are generated and may contain mistakes; the official description above is the record.
