{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92941 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92941 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92941 and fix it if it is affected.\n\nWhat it is: CVE-2026-92941 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92941 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n- vm2 (npm): affected from 3.11.3; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92941/ (Markdown: https://insights.sbomify.com/CVE-2026-92941/index.md)","id":"CVE-2026-92941","markdown":"https://insights.sbomify.com/CVE-2026-92941/index.md","name":"CVE-2026-92941","record":{"aliases":["CLEANSTART-2026-BS07911","ECHO-306b-24c3-45bd","GHSA-98xx-8mx4-x7cm","MINI-hgc2-9c39-75cq","ROOT-APP-NPM-CVE-2026-92941"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can manipulate the TLS trust store in vm2 sandboxes, allowing host HTTPS clients to accept malicious certificates and bypass security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L","version":"4.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"vm2 versions from 3.11.3 before 3.11.7 expose the host tls module to NodeVM sandbox code, allowing attackers to call tls.setDefaultCACertificates() and replace process-wide certificate authorities. Attackers with access to allowed tls and url builtins can use URLSearchParams to create host-realm arrays and manipulate the TLS trust store, enabling subsequent host HTTPS clients to accept attacker-controlled certificates.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 3.11.3 before 3.11.7 TLS Trust Store Manipulation","id":"CVE-2026-92941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.7 Timeout Bypass via FinalizationRegistry","id":"CVE-2026-92942"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-98xx-8mx4-x7cm"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.3"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-98xx-8mx4-x7cm"}],"prev":{"headline":"vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent","id":"CVE-2026-92940"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can manipulate the TLS trust store in vm2 sandboxes, allowing host HTTPS clients to accept malicious certificates and bypass security controls.","url":"https://insights.sbomify.com/CVE-2026-92941/"}