# CVE-2026-92941: vm2 3.11.3 before 3.11.7 TLS Trust Store Manipulation

> Attackers can manipulate the TLS trust store in vm2 sandboxes, allowing host HTTPS clients to accept malicious certificates and bypass security controls.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-BS07911, ECHO-306b-24c3-45bd, GHSA-98xx-8mx4-x7cm, MINI-hgc2-9c39-75cq, ROOT-APP-NPM-CVE-2026-92941

## What is CVE-2026-92941?

CVE-2026-92941 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 versions from 3.11.3 before 3.11.7 expose the host tls module to NodeVM sandbox code, allowing attackers to call tls.setDefaultCACertificates() and replace process-wide certificate authorities. Attackers with access to allowed tls and url builtins can use URLSearchParams to create host-realm arrays and manipulate the TLS trust store, enabling subsequent host HTTPS clients to accept attacker-controlled certificates.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-92941?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.11.3 | 3.11.7 |
| `vm2` | npm | From 3.11.3 | 3.11.7 |

## How do I fix CVE-2026-92941?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92941 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92941 and fix it if it is affected.

What it is: CVE-2026-92941 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92941 exists.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7
- vm2 (npm): affected from 3.11.3; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92941/ (Markdown: https://insights.sbomify.com/CVE-2026-92941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92941
- OSV: https://osv.dev/vulnerability/CVE-2026-92941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92941/
Summaries are generated and may contain mistakes; the official description above is the record.
