# CVE-2026-92944: vm2 3.10.2 through 3.11.6 Sandbox Escape via Promise Protector

> Attackers can escape the vm2 sandbox to execute arbitrary code on the host system by exploiting a Promise protector bypass in Node.js.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** CLEANSTART-2026-WY20719, ECHO-89d0-4de4-3380, GHSA-27g9-p43v-cw3v, MINI-6vxp-r3ww-2h52, ROOT-APP-NPM-CVE-2026-92944

## What is CVE-2026-92944?

CVE-2026-92944 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 versions 3.10.2 through 3.11.6 contain a sandbox escape vulnerability on Node.js 26 where Promise.prototype.finally() bypasses vm2's wrapper protections due to a stale PromiseThenLookupChain protector in V8 14.6. Attackers can exploit this by creating an async function that returns a Promise with an attacker-controlled constructor Symbol.species, allowing them to reach the host Function constructor and process object for arbitrary code execution.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-92944?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.10.2 | 3.11.7 |
| `vm2` | npm | From 3.10.2 | 3.11.7 |

## How do I fix CVE-2026-92944?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92944 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92944 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92944 and fix it if it is affected.

What it is: CVE-2026-92944 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92944 exists.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.10.2; fixed in 3.11.7
- vm2 (npm): affected from 3.10.2; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92944/ (Markdown: https://insights.sbomify.com/CVE-2026-92944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92944
- OSV: https://osv.dev/vulnerability/CVE-2026-92944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92944/
Summaries are generated and may contain mistakes; the official description above is the record.
