{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"There is no known exploitation of CVE-2026-92945 in the wild and no public exploit code.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92945 is a low-severity path traversal vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92945 and fix it if it is affected.\n\nWhat it is: CVE-2026-92945 is a low-severity path traversal vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92945 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.7\n- vm2 (npm): affected all versions; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92945/ (Markdown: https://insights.sbomify.com/CVE-2026-92945/index.md)","id":"CVE-2026-92945","markdown":"https://insights.sbomify.com/CVE-2026-92945/index.md","name":"CVE-2026-92945","record":{"aliases":["CLEANSTART-2026-WB52901","ECHO-8846-7fbc-2389","GHSA-7q3f-wx44-378m","MINI-6843-ch4f-rg4r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript sandbox library","requires_auth":"low_privilege","summary":"Attackers can bypass module allowlists in vm2 to load unauthorized packages, potentially leading to code execution within the sandbox.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"vm2 before 3.11.7 contains a module allowlist bypass vulnerability in isPathAllowedForModule that uses raw string prefix matching instead of boundary-anchored comparison. Attackers can reach non-allowlisted packages sharing a prefix with allowlisted modules by performing relative requires from allowlisted packages when transitive loading is disabled.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vm2 before 3.11.7 Module Allowlist Bypass via Prefix Matching","id":"CVE-2026-92945","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.7 Remote Code Execution via require.external","id":"CVE-2026-92946"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-7q3f-wx44-378m"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-7q3f-wx44-378m"}],"prev":{"headline":"vm2 3.10.2 through 3.11.6 Sandbox Escape via Promise Protector","id":"CVE-2026-92944"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can bypass module allowlists in vm2 to load unauthorized packages, potentially leading to code execution within the sandbox.","url":"https://insights.sbomify.com/CVE-2026-92945/"}