{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"There is no known exploitation of CVE-2026-92946 in the wild and no public exploit code.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92946 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92946 and fix it if it is affected.\n\nWhat it is: CVE-2026-92946 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92946 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.7\n- vm2 (npm): affected all versions; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92946/ (Markdown: https://insights.sbomify.com/CVE-2026-92946/index.md)","id":"CVE-2026-92946","markdown":"https://insights.sbomify.com/CVE-2026-92946/index.md","name":"CVE-2026-92946","record":{"aliases":["CLEANSTART-2026-DN17420","ECHO-43a8-b41f-3483","GHSA-j3hm-6rg5-mchv","MINI-fcrr-7j74-vq9c","ROOT-APP-NPM-CVE-2026-92946"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can execute arbitrary host commands if require.external is enabled without proper root restrictions in the vm2 sandbox library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-913","name":"Improper Control of Dynamically-Managed Code Resources"}],"description":"vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vm2 before 3.11.7 Remote Code Execution via require.external","id":"CVE-2026-92946","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.7 Memory Disclosure via Buffer Pool","id":"CVE-2026-92947"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-j3hm-6rg5-mchv"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-j3hm-6rg5-mchv"}],"prev":{"headline":"vm2 before 3.11.7 Module Allowlist Bypass via Prefix Matching","id":"CVE-2026-92945"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can execute arbitrary host commands if require.external is enabled without proper root restrictions in the vm2 sandbox library.","url":"https://insights.sbomify.com/CVE-2026-92946/"}