# CVE-2026-92946: vm2 before 3.11.7 Remote Code Execution via require.external

> Attackers can execute arbitrary host commands if require.external is enabled without proper root restrictions in the vm2 sandbox library.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-DN17420, ECHO-43a8-b41f-3483, GHSA-j3hm-6rg5-mchv, MINI-fcrr-7j74-vq9c, ROOT-APP-NPM-CVE-2026-92946

## What is CVE-2026-92946?

CVE-2026-92946 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-92946?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.7 |
| `vm2` | npm | All versions | 3.11.7 |

## How do I fix CVE-2026-92946?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92946 being exploited?

There is no known exploitation of CVE-2026-92946 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92946 and fix it if it is affected.

What it is: CVE-2026-92946 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92946 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.7
- vm2 (npm): affected all versions; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92946/ (Markdown: https://insights.sbomify.com/CVE-2026-92946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92946
- OSV: https://osv.dev/vulnerability/CVE-2026-92946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92946/
Summaries are generated and may contain mistakes; the official description above is the record.
