CVE-2026-92948 vm2 3.9.6 through 3.11.5 Sandbox Escape via node:test
Attackers can execute arbitrary code on the host by exploiting a sandbox escape in vm2 when the node:test builtin is explicitly allowed.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92948?
CVE-2026-92948 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
vm2 versions >= 3.9.6 and <= 3.11.6 are affected by a NodeVM builtin allowlist bypass that permits a sandbox escape on Node.js 24 and newer when the embedder explicitly allows the node:test builtin (e.g. require: { builtin: ['node:test'] }). On Node.js 24+, module.builtinModules exposes the scheme-only key node:test, which is not covered by vm2's family-based DANGEROUS_BUILTINS protection, so it is stored in the generic host-passthrough loader. Because requireImpl() in lib/setup-node-sandbox.js strips a single 'node:' prefix before the builtin lookup, sandbox code calling require('node:node:test') resolves to the stored node:test key and receives a readonly proxy to the host module. Calls to node:test.run() are forwarded to the host implementation, which spawns a separate Node process for process-isolated test execution and passes through attacker-controlled execArgv values; supplying --eval=<JavaScript> therefore executes arbitrary JavaScript in an unrestricted host Node process outside the NodeVM sandbox. Fixed in vm2 3.11.7.
Weakness: CWE-693
Which versions are affected by CVE-2026-92948?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.9.6 | 3.11.7 |
vm2 npm | From 3.9.6 | 3.11.7 |
How do I fix CVE-2026-92948?
Upgrade vm2 to 3.11.7 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-92948 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92948 exists.
Sources
Also known as CLEANSTART-2026-HG84830, ECHO-e8f1-baa7-9bb5, GHSA-qhwx-74w5-xhxq, MINI-55cq-376w-fpgc, ROOT-APP-NPM-CVE-2026-92948.