{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92948 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92948 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92948 and fix it if it is affected.\n\nWhat it is: CVE-2026-92948 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92948 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.9.6; fixed in 3.11.7\n- vm2 (npm): affected from 3.9.6; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92948/ (Markdown: https://insights.sbomify.com/CVE-2026-92948/index.md)","id":"CVE-2026-92948","markdown":"https://insights.sbomify.com/CVE-2026-92948/index.md","name":"CVE-2026-92948","record":{"aliases":["CLEANSTART-2026-HG84830","ECHO-e8f1-baa7-9bb5","GHSA-qhwx-74w5-xhxq","MINI-55cq-376w-fpgc","ROOT-APP-NPM-CVE-2026-92948"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on the host by exploiting a sandbox escape in vm2 when the node:test builtin is explicitly allowed.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"vm2 versions \u003e= 3.9.6 and \u003c= 3.11.6 are affected by a NodeVM builtin allowlist bypass that permits a sandbox escape on Node.js 24 and newer when the embedder explicitly allows the node:test builtin (e.g. require: { builtin: ['node:test'] }). On Node.js 24+, module.builtinModules exposes the scheme-only key node:test, which is not covered by vm2's family-based DANGEROUS_BUILTINS protection, so it is stored in the generic host-passthrough loader. Because requireImpl() in lib/setup-node-sandbox.js strips a single 'node:' prefix before the builtin lookup, sandbox code calling require('node:node:test') resolves to the stored node:test key and receives a readonly proxy to the host module. Calls to node:test.run() are forwarded to the host implementation, which spawns a separate Node process for process-isolated test execution and passes through attacker-controlled execArgv values; supplying --eval=\u003cJavaScript\u003e therefore executes arbitrary JavaScript in an unrestricted host Node process outside the NodeVM sandbox. Fixed in vm2 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 3.9.6 through 3.11.5 Sandbox Escape via node:test","id":"CVE-2026-92948","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 3.9.6 before 3.11.7 Sandbox Bypass via Accessor Descriptor","id":"CVE-2026-92949"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.9.6"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-qhwx-74w5-xhxq"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.9.6"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-qhwx-74w5-xhxq"}],"prev":{"headline":"vm2 before 3.11.7 Memory Disclosure via Buffer Pool","id":"CVE-2026-92947"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["patriksimek"]},"summary":"Attackers can execute arbitrary code on the host by exploiting a sandbox escape in vm2 when the node:test builtin is explicitly allowed.","url":"https://insights.sbomify.com/CVE-2026-92948/"}