# CVE-2026-92949: vm2 3.9.6 before 3.11.7 Sandbox Bypass via Accessor Descriptor

> Attackers can bypass vm2 sandbox restrictions to execute arbitrary code or escalate privileges by exploiting accessor property handling flaws.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** ECHO-c0b6-cb12-097d, GHSA-633r-hq9m-c4ff, MINI-rrrj-fpfx-qx8v

## What is CVE-2026-92949?

CVE-2026-92949 is a medium-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 versions from 3.9.6 before 3.11.7 fail to properly restrict access to accessor properties on frozen objects, allowing sandboxed scripts to bypass vm.freeze() and vm.readonly() protections. Attackers can use Object.getOwnPropertyDescriptor() or __lookupSetter__() to extract and invoke host object setters directly, mutating properties the embedder explicitly marked read-only.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2026-92949?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.9.6 | 3.11.7 |
| `vm2` | npm | From 3.9.6 | 3.11.7 |

## How do I fix CVE-2026-92949?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92949 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92949 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92949 and fix it if it is affected.

What it is: CVE-2026-92949 is a medium-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92949 exists.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.9.6; fixed in 3.11.7
- vm2 (npm): affected from 3.9.6; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92949/ (Markdown: https://insights.sbomify.com/CVE-2026-92949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92949
- OSV: https://osv.dev/vulnerability/CVE-2026-92949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92949/
Summaries are generated and may contain mistakes; the official description above is the record.
