{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92950 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92950 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-92950 and fix it if it is affected.\n\nWhat it is: CVE-2026-92950 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92950 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.7\n- vm2 (npm): affected all versions; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92950/ (Markdown: https://insights.sbomify.com/CVE-2026-92950/index.md)","id":"CVE-2026-92950","markdown":"https://insights.sbomify.com/CVE-2026-92950/index.md","name":"CVE-2026-92950","record":{"aliases":["CLEANSTART-2026-LI48838","ECHO-4756-8481-ea87","GHSA-jxxv-8r27-vm4p","MINI-mfph-7wq8-wq97","ROOT-APP-NPM-CVE-2026-92950"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can execute arbitrary code on the host by supplying a malicious script to the vm2 CLI, bypassing sandbox isolation.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-453","name":"Insecure Default Variable Initialization"}],"description":"vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process. Attackers can supply a malicious script file to the vm2 CLI that uses require(__filename) to re-execute itself in the host realm, bypassing sandbox isolation and accessing host modules like fs and child_process.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 before 3.11.7 Sandbox Escape via CLI require","id":"CVE-2026-92950","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.7 Module Allowlist Bypass via Custom Resolver","id":"CVE-2026-92951"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-jxxv-8r27-vm4p"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-jxxv-8r27-vm4p"}],"prev":{"headline":"vm2 3.9.6 before 3.11.7 Sandbox Bypass via Accessor Descriptor","id":"CVE-2026-92949"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can execute arbitrary code on the host by supplying a malicious script to the vm2 CLI, bypassing sandbox isolation.","url":"https://insights.sbomify.com/CVE-2026-92950/"}