# CVE-2026-92950: vm2 before 3.11.7 Sandbox Escape via CLI require

> Attackers can execute arbitrary code on the host by supplying a malicious script to the vm2 CLI, bypassing sandbox isolation.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-LI48838, ECHO-4756-8481-ea87, GHSA-jxxv-8r27-vm4p, MINI-mfph-7wq8-wq97, ROOT-APP-NPM-CVE-2026-92950

## What is CVE-2026-92950?

CVE-2026-92950 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process. Attackers can supply a malicious script file to the vm2 CLI that uses require(__filename) to re-execute itself in the host realm, bypassing sandbox isolation and accessing host modules like fs and child_process.

Weakness: CWE-453 (Insecure Default Variable Initialization)

## Which versions are affected by CVE-2026-92950?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.7 |
| `vm2` | npm | All versions | 3.11.7 |

## How do I fix CVE-2026-92950?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92950 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92950 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92950 and fix it if it is affected.

What it is: CVE-2026-92950 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92950 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.7
- vm2 (npm): affected all versions; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92950/ (Markdown: https://insights.sbomify.com/CVE-2026-92950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92950
- OSV: https://osv.dev/vulnerability/CVE-2026-92950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92950/
Summaries are generated and may contain mistakes; the official description above is the record.
