# CVE-2026-92951: vm2 before 3.11.7 Module Allowlist Bypass via Custom Resolver


- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-SU19502, ECHO-cf9b-87ca-645c, GHSA-c48m-32m9-vx93, MINI-7rqq-v3xg-f355, ROOT-APP-NPM-CVE-2026-92951

## What is CVE-2026-92951?

CVE-2026-92951 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. 

### Official description

vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-92951?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.7 |
| `vm2` | npm | All versions | 3.11.7 |

## How do I fix CVE-2026-92951?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92951 being exploited?

There is no known exploitation of CVE-2026-92951 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92951 and fix it if it is affected.

What it is: CVE-2026-92951 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-92951 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.7
- vm2 (npm): affected all versions; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92951/ (Markdown: https://insights.sbomify.com/CVE-2026-92951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92951
- OSV: https://osv.dev/vulnerability/CVE-2026-92951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92951/
Summaries are generated and may contain mistakes; the official description above is the record.
