CVE-2026-92952 vm2 3.11.4 through 3.11.6 Sandbox Symbol Filtering Bypass
Attackers can bypass sandbox stream state checks by exploiting unfiltered internal symbols, potentially corrupting host stream logic in vm2.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92952?
CVE-2026-92952 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vm2 versions 3.11.4 through 3.11.6 incompletely filter Node.js registered internal symbols across the sandbox boundary. The extraction filters in lib/setup-sandbox.js and the cross-realm symbol checks and write traps in lib/bridge.js use a fixed list of known dangerous registered symbols that omits nodejs.stream.disturbed and nodejs.stream.errored, which are exposed on host WebStream prototypes on newer Node.js releases (validated on Node.js v25.8.0). When the embedder exposes a host WebStream object and the host stream/web module to the sandbox, sandbox code can obtain the real host symbols via Object.getOwnPropertySymbols(streamWeb.ReadableStream.prototype) and use them as write keys on host stream objects, corrupting host-visible stream state — for example making stream.Readable.isDisturbed() return false for an already-consumed stream. This can bypass host logic that relies on Node's public stream-state helpers to enforce one-shot body consumption, reject errored streams, or decide whether a stream is safe to hand to another component. It is not a host code-execution primitive in the reported proof of vulnerability. This is an incomplete fix for the earlier nodejs.* symbol filtering issue. Fixed in vm2 3.11.7.
Weakness: CWE-669
Which versions are affected by CVE-2026-92952?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.11.4 | 3.11.7 |
vm2 npm | From 3.11.4 | 3.11.7 |
How do I fix CVE-2026-92952?
Upgrade vm2 to 3.11.7 or later.
Is CVE-2026-92952 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92952 exists.
Sources
Also known as CLEANSTART-2026-FF64850, ECHO-e013-9d17-e16a, GHSA-jf8q-945g-9q4c, MINI-whrw-7pmq-2wgp.