# CVE-2026-92956: vm2 3.10.1 through 3.11.6 Sandbox Escape via WebAssembly.compileStreaming

> Attackers can escape the vm2 sandbox to execute arbitrary code on the host system by exploiting WebAssembly streaming APIs.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-XJ45265, ECHO-0394-d2d0-d026, GHSA-wjwh-qqvp-g4p4, MINI-7vcq-8rpf-mqjv, ROOT-APP-NPM-CVE-2026-92956

## What is CVE-2026-92956?

CVE-2026-92956 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 versions 3.10.1 through 3.11.6 contain a sandbox escape reachable from a default `new VM()` sandbox when running on Node.js 26. WebAssembly.compileStreaming and WebAssembly.instantiateStreaming can produce a raw host-realm Promise that rejects with a host-realm error object; by controlling Symbol.species via Promise.prototype.finally, sandbox code receives that raw host error, walks from the host error constructor to the host Function constructor, and recovers the real host `process` object, gaining host Node.js capabilities (e.g. access to host modules such as fs) in the context of the process running the sandbox. No NodeVM, require permission, host object injection, or otherwise unsafe configuration is required. This is a bypass of the fix for GHSA-6j2x-vhqr-qr7q, which removed the JSPI entry points WebAssembly.promising and WebAssembly.Suspending. The issue is fixed in 3.11.7.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-92956?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.10.1 | 3.11.7 |
| `vm2` | npm | From 3.10.1 | 3.11.7 |

## How do I fix CVE-2026-92956?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92956 being exploited?

There is no known exploitation of CVE-2026-92956 in the wild and no public exploit code.

Public exploit code:

- https://github.com/AraxyAI/CVE-2026-92956__vm2__test__20261012 (github_poc): https://github.com/AraxyAI/CVE-2026-92956__vm2__test__20261012

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92956 and fix it if it is affected.

What it is: CVE-2026-92956 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92956 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.10.1; fixed in 3.11.7
- vm2 (npm): affected from 3.10.1; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92956/ (Markdown: https://insights.sbomify.com/CVE-2026-92956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92956
- OSV: https://osv.dev/vulnerability/CVE-2026-92956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92956/
Summaries are generated and may contain mistakes; the official description above is the record.
