{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92957 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92957 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92957 and fix it if it is affected.\n\nWhat it is: CVE-2026-92957 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92957 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.7\n- vm2 (npm): affected all versions; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92957/ (Markdown: https://insights.sbomify.com/CVE-2026-92957/index.md)","id":"CVE-2026-92957","markdown":"https://insights.sbomify.com/CVE-2026-92957/index.md","name":"CVE-2026-92957","record":{"aliases":["CLEANSTART-2026-VO63729","ECHO-62cc-9713-aaf7","GHSA-8686-vhfx-7r3j","MINI-fp9r-38jm-fgmv","ROOT-APP-NPM-CVE-2026-92957"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandboxing library","requires_auth":"low_privilege","summary":"Attackers can bypass sandbox restrictions to execute arbitrary host commands by exploiting a flaw in the builtin module deny-list logic.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"vm2 through 3.11.6 does not normalize `node:`-prefixed builtin specifiers when evaluating user-supplied negative (deny) entries in a NodeVM wildcard require policy. Although NodeVM strips the `node:` prefix during require() resolution, negative wildcard entries are matched by exact string comparison against the canonical builtin names, so a policy such as `new NodeVM({ require: { builtin: ['*', '-node:child_process'] } })` fails to deny the canonical `child_process` module. Sandboxed code can therefore obtain the host `child_process` builtin via `require('child_process')` or `require('node:child_process')`, gaining references to process-spawning APIs such as execSync and spawn, which is equivalent to host command-execution capability for untrusted sandbox code. Fixed in vm2 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 before 3.11.7 NodeVM Builtin Deny-List Bypass via node: Prefix","id":"CVE-2026-92957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.7 Denylist Bypass via fs/promises","id":"CVE-2026-92958"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-8686-vhfx-7r3j"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-8686-vhfx-7r3j"}],"prev":{"headline":"vm2 3.10.1 through 3.11.6 Sandbox Escape via WebAssembly.compileStreaming","id":"CVE-2026-92956"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["patriksimek"]},"summary":"Attackers can bypass sandbox restrictions to execute arbitrary host commands by exploiting a flaw in the builtin module deny-list logic.","url":"https://insights.sbomify.com/CVE-2026-92957/"}