# CVE-2026-92957: vm2 before 3.11.7 NodeVM Builtin Deny-List Bypass via node: Prefix

> Attackers can bypass sandbox restrictions to execute arbitrary host commands by exploiting a flaw in the builtin module deny-list logic.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** CLEANSTART-2026-VO63729, ECHO-62cc-9713-aaf7, GHSA-8686-vhfx-7r3j, MINI-fp9r-38jm-fgmv, ROOT-APP-NPM-CVE-2026-92957

## What is CVE-2026-92957?

CVE-2026-92957 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vm2 through 3.11.6 does not normalize `node:`-prefixed builtin specifiers when evaluating user-supplied negative (deny) entries in a NodeVM wildcard require policy. Although NodeVM strips the `node:` prefix during require() resolution, negative wildcard entries are matched by exact string comparison against the canonical builtin names, so a policy such as `new NodeVM({ require: { builtin: ['*', '-node:child_process'] } })` fails to deny the canonical `child_process` module. Sandboxed code can therefore obtain the host `child_process` builtin via `require('child_process')` or `require('node:child_process')`, gaining references to process-spawning APIs such as execSync and spawn, which is equivalent to host command-execution capability for untrusted sandbox code. Fixed in vm2 3.11.7.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-92957?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.7 |
| `vm2` | npm | All versions | 3.11.7 |

## How do I fix CVE-2026-92957?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92957 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92957 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92957 and fix it if it is affected.

What it is: CVE-2026-92957 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92957 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.7
- vm2 (npm): affected all versions; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92957/ (Markdown: https://insights.sbomify.com/CVE-2026-92957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92957
- OSV: https://osv.dev/vulnerability/CVE-2026-92957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92957/
Summaries are generated and may contain mistakes; the official description above is the record.
