{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92958 exists.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92958 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92958 and fix it if it is affected.\n\nWhat it is: CVE-2026-92958 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92958 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.7\n- vm2 (npm): affected all versions; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92958/ (Markdown: https://insights.sbomify.com/CVE-2026-92958/index.md)","id":"CVE-2026-92958","markdown":"https://insights.sbomify.com/CVE-2026-92958/index.md","name":"CVE-2026-92958","record":{"aliases":["CLEANSTART-2026-YW49143","CLSA-2026-1790940570","ECHO-9eab-0368-ced7","GHSA-6rh5-qq4q-97xh","MINI-8q28-jm93-r69v","ROOT-APP-NPM-CVE-2026-92958"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"low_privilege","summary":"Attackers can bypass sandbox restrictions to access filesystem APIs and execute code when specific denylist configurations are used.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 before 3.11.7 Denylist Bypass via fs/promises","id":"CVE-2026-92958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.8 allowAsync Bypass via Promise Thenable","id":"CVE-2026-92959"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-6rh5-qq4q-97xh"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-6rh5-qq4q-97xh"}],"prev":{"headline":"vm2 before 3.11.7 NodeVM Builtin Deny-List Bypass via node: Prefix","id":"CVE-2026-92957"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-18","vendors":["patriksimek"]},"summary":"Attackers can bypass sandbox restrictions to access filesystem APIs and execute code when specific denylist configurations are used.","url":"https://insights.sbomify.com/CVE-2026-92958/"}