# CVE-2026-92958: vm2 before 3.11.7 Denylist Bypass via fs/promises

> Attackers can bypass sandbox restrictions to access filesystem APIs and execute code when specific denylist configurations are used.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-YW49143, CLSA-2026-1790940570, ECHO-9eab-0368-ced7, GHSA-6rh5-qq4q-97xh, MINI-8q28-jm93-r69v, ROOT-APP-NPM-CVE-2026-92958

## What is CVE-2026-92958?

CVE-2026-92958 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-92958?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.7 |
| `vm2` | npm | All versions | 3.11.7 |

## How do I fix CVE-2026-92958?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92958 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92958 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92958 and fix it if it is affected.

What it is: CVE-2026-92958 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92958 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.7
- vm2 (npm): affected all versions; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92958/ (Markdown: https://insights.sbomify.com/CVE-2026-92958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92958
- OSV: https://osv.dev/vulnerability/CVE-2026-92958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92958/
Summaries are generated and may contain mistakes; the official description above is the record.
