# CVE-2026-92959: vm2 before 3.11.8 allowAsync Bypass via Promise Thenable

> Attacker bypasses async restrictions in vm2 sandbox to execute code after timeout, risking resource exhaustion or unauthorized execution.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** CLEANSTART-2026-WX83139, ECHO-2f77-0a3f-c878, GHSA-f8gf-w286-fmq2, MINI-wf8x-hcvr-ff7x, ROOT-APP-NPM-CVE-2026-92959

## What is CVE-2026-92959?

CVE-2026-92959 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vm2 before 3.11.8 does not fully enforce the allowAsync: false option in VM and NodeVM. While localPromise.prototype.then is replaced with a handler that throws 'Async not available', the sandbox's Promise static methods (Promise.resolve, Promise.all, Promise.race, Promise.any, and Promise.allSettled) still assimilate attacker-supplied thenables: native promise resolution performs PromiseResolveThenableJob and invokes the sandboxed code's then method in a microtask without passing through the patched then, so the async restriction is never applied. As a result, sandboxed script can schedule work that runs after VM.run() or NodeVM.run() has returned and outside the configured timeout, continuing to execute after the host believes execution is complete.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-92959?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.8 |
| `vm2` | npm | All versions | 3.11.8 |

## How do I fix CVE-2026-92959?

Upgrade vm2 to 3.11.8 or later.

## Is CVE-2026-92959 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92959 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92959 and fix it if it is affected.

What it is: CVE-2026-92959 is a high-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92959 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.8
- vm2 (npm): affected all versions; fixed in 3.11.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92959/ (Markdown: https://insights.sbomify.com/CVE-2026-92959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92959
- OSV: https://osv.dev/vulnerability/CVE-2026-92959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92959/
Summaries are generated and may contain mistakes; the official description above is the record.
