# CVE-2026-92960: vm2 before 3.11.6 Process-wide State Exposure via os and dns

> Attackers can read host process identity and hijack DNS resolution by exploiting insufficient sandbox restrictions on os and dns modules.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-EQ29985, ECHO-a343-4f0a-64e7, GHSA-m5w8-4gq2-6f8x, GHSA-qj2x-7x9q-qgm7, MINI-hw8w-gfqc-mvp2, ROOT-APP-NPM-GHSA-m5w8-4gq2-6f8x

## What is CVE-2026-92960?

CVE-2026-92960 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.11.6 fails to restrict access to os and dns builtins under the builtin: ['*'] configuration, allowing sandbox code to read host process identity and network topology. Attackers can invoke dns.setServers() to hijack the host process DNS resolver globally, redirecting all subsequent host DNS queries through an attacker-controlled resolver.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-92960?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.6 |
| `vm2` | npm | All versions | 3.11.6 |

## How do I fix CVE-2026-92960?

Upgrade vm2 to 3.11.6 or later.

## Is CVE-2026-92960 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92960 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92960 and fix it if it is affected.

What it is: CVE-2026-92960 is a critical vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92960 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.6
- vm2 (npm): affected all versions; fixed in 3.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92960/ (Markdown: https://insights.sbomify.com/CVE-2026-92960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92960
- OSV: https://osv.dev/vulnerability/CVE-2026-92960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92960/
Summaries are generated and may contain mistakes; the official description above is the record.
