{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"There is no known exploitation of CVE-2026-92961 in the wild and no public exploit code.","fix":"Upgrade vm2 to 3.11.6 or later.","what":"CVE-2026-92961 is a high-severity denial of service vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92961 and fix it if it is affected.\n\nWhat it is: CVE-2026-92961 is a high-severity denial of service vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92961 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.6\n- vm2 (npm): affected all versions; fixed in 3.11.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92961/ (Markdown: https://insights.sbomify.com/CVE-2026-92961/index.md)","id":"CVE-2026-92961","markdown":"https://insights.sbomify.com/CVE-2026-92961/index.md","name":"CVE-2026-92961","record":{"aliases":["CLEANSTART-2026-EM16242","ECHO-d702-6934-d30e","GHSA-3m4j-9x2m-pq7h","GHSA-v836-6xw4-9cx3","MINI-qfg7-298q-94rc","ROOT-APP-NPM-GHSA-v836-6xw4-9cx3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript sandbox library","requires_auth":"none","summary":"Attackers can exhaust host memory by bypassing allocation limits in the vm2 JavaScript sandbox library, causing denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"vm2 before 3.11.6 fails to enforce bufferAllocLimit on ArrayBuffer, SharedArrayBuffer, and TypedArray constructors, allowing attackers to allocate arbitrary host memory. Attackers can bypass the buffer allocation cap by using these V8 intrinsics to exhaust host process memory and trigger out-of-memory conditions.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vm2 before 3.11.6 Memory Exhaustion DoS via bufferAllocLimit Bypass","id":"CVE-2026-92961","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 before 3.11.4 Defense Invariant Violation via setup-sandbox.js","id":"CVE-2026-92962"},"packages":[{"ecosystem":"npm","fixed":["3.11.6"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-v836-6xw4-9cx3"},{"ecosystem":"npm","fixed":["3.11.6"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-v836-6xw4-9cx3"}],"prev":{"headline":"vm2 before 3.11.6 Process-wide State Exposure via os and dns","id":"CVE-2026-92960"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-21","vendors":["patriksimek"]},"summary":"Attackers can exhaust host memory by bypassing allocation limits in the vm2 JavaScript sandbox library, causing denial of service.","url":"https://insights.sbomify.com/CVE-2026-92961/"}