# CVE-2026-92961: vm2 before 3.11.6 Memory Exhaustion DoS via bufferAllocLimit Bypass

> Attackers can exhaust host memory by bypassing allocation limits in the vm2 JavaScript sandbox library, causing denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** CLEANSTART-2026-EM16242, ECHO-d702-6934-d30e, GHSA-3m4j-9x2m-pq7h, GHSA-v836-6xw4-9cx3, MINI-qfg7-298q-94rc, ROOT-APP-NPM-GHSA-v836-6xw4-9cx3

## What is CVE-2026-92961?

CVE-2026-92961 is a high-severity denial of service vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.11.6 fails to enforce bufferAllocLimit on ArrayBuffer, SharedArrayBuffer, and TypedArray constructors, allowing attackers to allocate arbitrary host memory. Attackers can bypass the buffer allocation cap by using these V8 intrinsics to exhaust host process memory and trigger out-of-memory conditions.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-92961?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.6 |
| `vm2` | npm | All versions | 3.11.6 |

## How do I fix CVE-2026-92961?

Upgrade vm2 to 3.11.6 or later.

## Is CVE-2026-92961 being exploited?

There is no known exploitation of CVE-2026-92961 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92961 and fix it if it is affected.

What it is: CVE-2026-92961 is a high-severity denial of service vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92961 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.6
- vm2 (npm): affected all versions; fixed in 3.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92961/ (Markdown: https://insights.sbomify.com/CVE-2026-92961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92961
- OSV: https://osv.dev/vulnerability/CVE-2026-92961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92961/
Summaries are generated and may contain mistakes; the official description above is the record.
