CVE-2026-92962 vm2 before 3.11.4 Defense Invariant Violation via setup-sandbox.js

Low 2.1 Published Updated

Sandboxed code can intercept stack trace lines via prototype pollution, causing an information side channel in the vm2 JavaScript sandbox library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92962?

CVE-2026-92962 is a low-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

vm2 is a sandbox for running untrusted JavaScript. In vm2 versions up to and including 3.11.3, the defaultSandboxPrepareStackTrace function in lib/setup-sandbox.js builds its output array using prototype-walking index assignment (lines[lines.length] = value) rather than a prototype-bypassing define-property primitive. Because this bridge-internal array is allocated in the sandbox realm, code inside the sandbox can install an accessor on Array.prototype for the relevant index; the accessor is then invoked whenever the sandbox reads error.stack (or otherwise triggers Error.prepareStackTrace), allowing sandbox code to observe and intercept each stack-trace line written by the bridge. The same pattern is used in the error-handling (catch) branch. The values written are formatted strings only, so the practical impact is limited to an information side channel and a violation of vm2's bridge-container defense invariant rather than a sandbox escape; the vendor rates the issue Low. The issue is fixed in vm2 3.11.4, which installs each entry as an own data property via Reflect.defineProperty.

Weakness: CWE-693

Which versions are affected by CVE-2026-92962?

2 open source packages ship an affected version, including vm2.

PackageAffectedFixed in
vm2 npmAll versions3.11.4
vm2 npmAll versions3.11.4

How do I fix CVE-2026-92962?

Upgrade vm2 to 3.11.4 or later.

Is CVE-2026-92962 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92962 exists.

Sources

Also known as ECHO-b5b8-7f40-339a, GHSA-2c9f-f88g-g76p, GHSA-q3fm-4wcw-g57x, MINI-m82w-4qp7-ch75.

Is CVE-2026-92962 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free