# CVE-2026-92962: vm2 before 3.11.4 Defense Invariant Violation via setup-sandbox.js

> Sandboxed code can intercept stack trace lines via prototype pollution, causing an information side channel in the vm2 JavaScript sandbox library.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** ECHO-b5b8-7f40-339a, GHSA-2c9f-f88g-g76p, GHSA-q3fm-4wcw-g57x, MINI-m82w-4qp7-ch75

## What is CVE-2026-92962?

CVE-2026-92962 is a low-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

vm2 is a sandbox for running untrusted JavaScript. In vm2 versions up to and including 3.11.3, the defaultSandboxPrepareStackTrace function in lib/setup-sandbox.js builds its output array using prototype-walking index assignment (lines[lines.length] = value) rather than a prototype-bypassing define-property primitive. Because this bridge-internal array is allocated in the sandbox realm, code inside the sandbox can install an accessor on Array.prototype for the relevant index; the accessor is then invoked whenever the sandbox reads error.stack (or otherwise triggers Error.prepareStackTrace), allowing sandbox code to observe and intercept each stack-trace line written by the bridge. The same pattern is used in the error-handling (catch) branch. The values written are formatted strings only, so the practical impact is limited to an information side channel and a violation of vm2's bridge-container defense invariant rather than a sandbox escape; the vendor rates the issue Low. The issue is fixed in vm2 3.11.4, which installs each entry as an own data property via Reflect.defineProperty.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-92962?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.4 |
| `vm2` | npm | All versions | 3.11.4 |

## How do I fix CVE-2026-92962?

Upgrade vm2 to 3.11.4 or later.

## Is CVE-2026-92962 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92962 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92962 and fix it if it is affected.

What it is: CVE-2026-92962 is a low-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92962 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.4
- vm2 (npm): affected all versions; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92962/ (Markdown: https://insights.sbomify.com/CVE-2026-92962/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92962
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92962
- OSV: https://osv.dev/vulnerability/CVE-2026-92962

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92962/
Summaries are generated and may contain mistakes; the official description above is the record.
