# CVE-2026-92966: Appointment Booking Plugin <= 5.7.0 - Unauthenticated Arbitrary Shortcode Execution via First/Last Name Field

> Unauthenticated attackers can execute arbitrary shortcodes via the booking name field, potentially leading to code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-cgqj-c6wx-f7r6

## What is CVE-2026-92966?

CVE-2026-92966 is a critical code injection vulnerability in Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The The Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.7.0. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The payload is planted during the unauthenticated booking flow and triggered when the Customer Cabinet block rendered by render_customer_dashboard() outputs the stored name into the content stream, where WordPress core's do_shortcode filter at priority 11 re-parses and executes it.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-92966?


## How do I fix CVE-2026-92966?

No fix has been published for CVE-2026-92966 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92966 being exploited?

There is no known exploitation of CVE-2026-92966 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-92966 — WordPress LatePoint ≤5.7.0 unauthenticated stored shortcode execution (CVSS 9.1, CWE-94). PoCbit mass-exploit PoC: plant [caption]/custom shortcode in booking first name → Customer Cabinet block double do_shortcode; fixed in 5.7.1. No API key. check/exploit/mass, hits.txt & exploited.txt, https://pocbit.org/pocs/cve-2026-92966 (github_poc): https://github.com/murrez/CVE-2026-92966

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92966 and fix it if it is affected.

What it is: CVE-2026-92966 is a critical code injection vulnerability in Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92966 in the wild and no public exploit code.

Affected product: Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92966/ (Markdown: https://insights.sbomify.com/CVE-2026-92966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92966
- OSV: https://osv.dev/vulnerability/CVE-2026-92966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92966/
Summaries are generated and may contain mistakes; the official description above is the record.
