{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-92973 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-92973 is a medium-severity cross-site scripting vulnerability in pycontribs ansi2html, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-92973 and fix it if it is affected.\n\nWhat it is: CVE-2026-92973 is a medium-severity cross-site scripting vulnerability in pycontribs ansi2html, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-92973 in the wild and no public exploit code.\n\nAffected product: pycontribs ansi2html. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92973/ (Markdown: https://insights.sbomify.com/CVE-2026-92973/index.md)","id":"CVE-2026-92973","markdown":"https://insights.sbomify.com/CVE-2026-92973/index.md","name":"CVE-2026-92973","record":{"aliases":["DEBIAN-CVE-2026-92973","GHSA-98hw-5x94-6hwv","UBUNTU-CVE-2026-92973","openSUSE-SU-2026:11815-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ANSI to HTML library","requires_auth":"none","summary":"Attackers can inject malicious scripts via OSC 8 hyperlinks in ANSI text, leading to arbitrary code execution in browsers displaying converted output.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ansi2html 1.7.0a0 through 1.9.3 Cross-Site Scripting via OSC 8","id":"CVE-2026-92973","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Photo Gallery by 10Web \u003c= 1.8.46 - Reflected Cross-Site Scripting via 'thumb_url' Parameter","id":"CVE-2026-92974"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.9.5-1.1"],"introduced":["0"],"last_affected":[],"package":"python-ansi2html","purl":"pkg:rpm/opensuse/python-ansi2html\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11815-1"}],"prev":{"headline":"SGLang through 0.5.19 Unauthenticated Route Poisoning via PUT endpoint","id":"CVE-2026-92972"},"products":["ansi2html"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["pycontribs"]},"summary":"Attackers can inject malicious scripts via OSC 8 hyperlinks in ANSI text, leading to arbitrary code execution in browsers displaying converted output.","url":"https://insights.sbomify.com/CVE-2026-92973/"}