CVE-2026-9300 omec-project amf NGSetupRequest memory corruption
Remote attackers can exploit memory corruption in the AMF NGSetupRequest handler to potentially execute code or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-9300?
CVE-2026-9300 is a medium-severity memory corruption vulnerability in omec-project amf, published on 23 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability has been found in omec-project amf up to 2.1.1. This affects an unknown part of the component NGSetupRequest Handler. Such manipulation leads to memory corruption. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. It is best practice to apply a patch to resolve this issue.
Weakness: CWE-119
Which versions are affected by CVE-2026-9300?
3 open source packages ship an affected version, including github.com/omec-project/amf.
| Package | Affected | Fixed in |
|---|---|---|
github.com/omec-project/amf Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |
github.com/omec-project/amf Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |
github.com/omec-project/amf Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |
How do I fix CVE-2026-9300?
Upgrade github.com/omec-project/amf to 1.7.1-0.20260421213846-34bc6724acc9 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-9300 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9300 exists.
Sources
Also known as GHSA-6p7m-c3mw-4gmw, GO-2026-5842.