# CVE-2026-9301: omec-project amf NGReset Message memory corruption

> Remote attackers can trigger memory corruption in the AMF NGReset Message Handler, potentially leading to code execution or service disruption.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-qm7q-rcm2-3frc, GO-2026-5844

## What is CVE-2026-9301?

CVE-2026-9301 is a medium-severity memory corruption vulnerability in omec-project amf, published on 23 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in omec-project amf up to 2.1.1. This vulnerability affects unknown code of the component NGReset Message Handler. Performing a manipulation results in memory corruption. The attack is possible to be carried out remotely. The exploit has been made public and could be used. It is recommended to apply a patch to fix this issue.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-9301?

3 open source packages ship an affected version, including github.com/omec-project/amf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/omec-project/amf` | Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |
| `github.com/omec-project/amf` | Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |
| `github.com/omec-project/amf` | Go | All versions | 1.7.1-0.20260421213846-34bc6724acc9 |

## How do I fix CVE-2026-9301?

Upgrade github.com/omec-project/amf to 1.7.1-0.20260421213846-34bc6724acc9 or later.

## Is CVE-2026-9301 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9301 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9301 and fix it if it is affected.

What it is: CVE-2026-9301 is a medium-severity memory corruption vulnerability in omec-project amf, published on 23 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9301 exists.

Affected packages and fixed versions:
- github.com/omec-project/amf (Go): affected all versions; fixed in 1.7.1-0.20260421213846-34bc6724acc9
- github.com/omec-project/amf (Go): affected all versions; fixed in 1.7.1-0.20260421213846-34bc6724acc9
- github.com/omec-project/amf (Go): affected all versions; fixed in 1.7.1-0.20260421213846-34bc6724acc9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9301/ (Markdown: https://insights.sbomify.com/CVE-2026-9301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9301
- OSV: https://osv.dev/vulnerability/CVE-2026-9301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9301/
Summaries are generated and may contain mistakes; the official description above is the record.
