{"answers":{"affected":"3 open source packages ship an affected version, including tablib.","exploited":"There is no known exploitation of CVE-2026-9318 in the wild and no public exploit code.","fix":"Upgrade tablib to 3.10.0 or later.","what":"CVE-2026-9318 is a medium-severity cross-site scripting vulnerability in Jazzband tablib, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-9318 and fix it if it is affected.\n\nWhat it is: CVE-2026-9318 is a medium-severity cross-site scripting vulnerability in Jazzband tablib, published on 12 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-9318 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tablib (PyPI): affected all versions; fixed in 3.10.0\n- tablib (PyPI): affected all versions; fixed in 3.10.0\n- tablib (PyPI): affected all versions; fixed in 3.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9318/ (Markdown: https://insights.sbomify.com/CVE-2026-9318/index.md)","id":"CVE-2026-9318","markdown":"https://insights.sbomify.com/CVE-2026-9318/index.md","name":"CVE-2026-9318","record":{"aliases":["DEBIAN-CVE-2026-9318","ECHO-5ee8-23ed-cfb4","GHSA-gqgw-jghv-mxwx","PYSEC-2026-3702","UBUNTU-CVE-2026-9318","openSUSE-SU-2026:11533-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python data library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript via stored XSS in tablib HTML exports by embedding malicious payloads in dataset titles, leading to session hijacking and data exposure.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"tablib prior to 3.10.0 contains a stored cross-site scripting vulnerability in the HTML export functionality that allows attackers to execute arbitrary JavaScript by embedding malicious payloads in dataset titles, which are interpolated unsanitized into HTML output via the export_book method in the _html.py format handler. Attackers can rename worksheet sheets in imported files such as XLSX, ODS, XLS, or YAML with script payloads that are assigned to the Dataset title attribute and rendered unescaped inside an HTML h3 tag, leading to session hijacking, unauthorized administrative actions, and sensitive data exposure when the output is rendered in a browser.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tablib versions prior to 3.10.0 Stored XSS via HTML Export Dataset Title","id":"CVE-2026-9318","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"IBM WebSphere Application Server is affected by a remote code execution vulnerability","id":"CVE-2026-9319"},"packages":[{"ecosystem":"PyPI","fixed":["3.10.0"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":null,"source":"GHSA-gqgw-jghv-mxwx"},{"ecosystem":"PyPI","fixed":["3.10.0"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":"pkg:pypi/tablib","source":"GHSA-gqgw-jghv-mxwx"},{"ecosystem":"PyPI","fixed":["3.10.0"],"introduced":["0"],"last_affected":[],"package":"tablib","purl":"pkg:pypi/tablib","source":"PYSEC-2026-3702"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.10.0-1.1"],"introduced":["0"],"last_affected":[],"package":"python-tablib","purl":"pkg:rpm/opensuse/python-tablib\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11533-1"}],"prev":{"headline":"Nango \u003c 0.71.6 Missing Authentication RCE via runner tRPC server","id":"CVE-2026-9317"},"products":["tablib"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["Jazzband"]},"summary":"Attackers can execute arbitrary JavaScript via stored XSS in tablib HTML exports by embedding malicious payloads in dataset titles, leading to session hijacking and data exposure.","url":"https://insights.sbomify.com/CVE-2026-9318/"}