CVE-2026-93337 NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection

High 8.5 Published Updated

Local attackers can inject pppd directives to load malicious shared objects, achieving root code execution in NetworkManager-l2tp.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-93337?

CVE-2026-93337 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

Weakness: CWE-88

Which versions are affected by CVE-2026-93337?

How do I fix CVE-2026-93337?

Upgrade to a fixed version.

Is CVE-2026-93337 being exploited?

There is no known exploitation of CVE-2026-93337 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-93337, GHSA-rp84-8h2r-5xc3, UBUNTU-CVE-2026-93337.

Is CVE-2026-93337 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free