{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-93337 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-93337 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-93337 and fix it if it is affected.\n\nWhat it is: CVE-2026-93337 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-93337 in the wild and no public exploit code.\n\nAffected product: nm-l2tp NetworkManager-l2tp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93337/ (Markdown: https://insights.sbomify.com/CVE-2026-93337/index.md)","id":"CVE-2026-93337","markdown":"https://insights.sbomify.com/CVE-2026-93337/index.md","name":"CVE-2026-93337","record":{"aliases":["DEBIAN-CVE-2026-93337","GHSA-rp84-8h2r-5xc3","UBUNTU-CVE-2026-93337"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"NetworkManager l2tp plugin","requires_auth":"low_privilege","summary":"Local attackers can inject pppd directives to load malicious shared objects, achieving root code execution in NetworkManager-l2tp.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection","id":"CVE-2026-93337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Grandstream GWN7660ELR \u003c 1.0.27.6 Information Disclosure via SNMP Default Community String","id":"CVE-2026-93338"},"packages":[],"prev":{"headline":"Missing authorization in the unit resources download route in Juju controllers","id":"CVE-2026-93336"},"products":["NetworkManager-l2tp"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["nm-l2tp"]},"summary":"Local attackers can inject pppd directives to load malicious shared objects, achieving root code execution in NetworkManager-l2tp.","url":"https://insights.sbomify.com/CVE-2026-93337/"}