# CVE-2026-93337: NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection

> Local attackers can inject pppd directives to load malicious shared objects, achieving root code execution in NetworkManager-l2tp.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-93337, GHSA-rp84-8h2r-5xc3, UBUNTU-CVE-2026-93337

## What is CVE-2026-93337?

CVE-2026-93337 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-93337?


## How do I fix CVE-2026-93337?

Upgrade to a fixed version.

## Is CVE-2026-93337 being exploited?

There is no known exploitation of CVE-2026-93337 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93337 and fix it if it is affected.

What it is: CVE-2026-93337 is a high-severity vulnerability in nm-l2tp NetworkManager-l2tp, published on 17 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93337 in the wild and no public exploit code.

Affected product: nm-l2tp NetworkManager-l2tp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93337/ (Markdown: https://insights.sbomify.com/CVE-2026-93337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93337
- OSV: https://osv.dev/vulnerability/CVE-2026-93337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93337/
Summaries are generated and may contain mistakes; the official description above is the record.
