{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-93405 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-93405 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-93405 is a medium-severity cross-site scripting vulnerability in Foundry376 Mailspring, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-93405 and fix it if it is affected.\n\nWhat it is: CVE-2026-93405 is a medium-severity cross-site scripting vulnerability in Foundry376 Mailspring, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-93405 in the wild and no public exploit code.\n\nAffected product: Foundry376 Mailspring. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93405/ (Markdown: https://insights.sbomify.com/CVE-2026-93405/index.md)","id":"CVE-2026-93405","markdown":"https://insights.sbomify.com/CVE-2026-93405/index.md","name":"CVE-2026-93405","record":{"aliases":["GHSA-px2g-jhg5-c6gh"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mailspring email client","requires_auth":"none","summary":"Remote attackers can execute scripts in Mailspring's preview renderer via malicious attachments, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mailspring is a fast, cross-platform, open-source email client. Prior to 1.17.0, attachment quick preview converts Markdown, DOCX, and XLSX attachments with Snarkdown, Mammoth, and SheetJS and inserts the resulting HTML into the preview document through innerHTML without sanitization. A remote sender can craft a supported attachment whose converted HTML executes script when a recipient opens quick preview. The preview renderer has no direct Node or Electron access, but injected script can reach the IPC surface exposed to the quick-preview renderer. This issue alone provides script execution in the preview renderer; separate path-traversal and renderer-controlled file-write vulnerabilities are required for the documented persistent code-execution chain. This issue is fixed in version 1.17.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Mailspring: Stored XSS in attachment quick preview (unsanitized Markdown/DOCX/XLSX conversion)","id":"CVE-2026-93405","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint","id":"CVE-2026-93421"},"packages":[],"prev":{"headline":"Information disclosure in Online Scheduling and Appointment Booking System – Bookly","id":"CVE-2026-93399"},"products":["Mailspring"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["Foundry376"]},"summary":"Remote attackers can execute scripts in Mailspring's preview renderer via malicious attachments, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-93405/"}