# CVE-2026-93405: Mailspring: Stored XSS in attachment quick preview (unsanitized Markdown/DOCX/XLSX conversion)

> Remote attackers can execute scripts in Mailspring's preview renderer via malicious attachments, potentially leading to code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-px2g-jhg5-c6gh

## What is CVE-2026-93405?

CVE-2026-93405 is a medium-severity cross-site scripting vulnerability in Foundry376 Mailspring, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mailspring is a fast, cross-platform, open-source email client. Prior to 1.17.0, attachment quick preview converts Markdown, DOCX, and XLSX attachments with Snarkdown, Mammoth, and SheetJS and inserts the resulting HTML into the preview document through innerHTML without sanitization. A remote sender can craft a supported attachment whose converted HTML executes script when a recipient opens quick preview. The preview renderer has no direct Node or Electron access, but injected script can reach the IPC surface exposed to the quick-preview renderer. This issue alone provides script execution in the preview renderer; separate path-traversal and renderer-controlled file-write vulnerabilities are required for the documented persistent code-execution chain. This issue is fixed in version 1.17.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-93405?


## How do I fix CVE-2026-93405?

No fix has been published for CVE-2026-93405 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-93405 being exploited?

There is no known exploitation of CVE-2026-93405 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93405 and fix it if it is affected.

What it is: CVE-2026-93405 is a medium-severity cross-site scripting vulnerability in Foundry376 Mailspring, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-93405 in the wild and no public exploit code.

Affected product: Foundry376 Mailspring. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93405/ (Markdown: https://insights.sbomify.com/CVE-2026-93405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93405
- OSV: https://osv.dev/vulnerability/CVE-2026-93405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93405/
Summaries are generated and may contain mistakes; the official description above is the record.
