{"answers":{"affected":"3 open source packages ship an affected version, including mesop.","exploited":"There is no known exploitation of CVE-2026-93421 in the wild and no public exploit code.","fix":"Upgrade mesop to 1.3.4 or later.","what":"CVE-2026-93421 is a medium-severity vulnerability in mesop-dev mesop, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-93421 and fix it if it is affected.\n\nWhat it is: CVE-2026-93421 is a medium-severity vulnerability in mesop-dev mesop, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-93421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mesop (PyPI): affected all versions; fixed in 1.3.4\n- mesop (PyPI): affected all versions; fixed in 1.3.4\n- mesop (PyPI): affected all versions; fixed in 1.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93421/ (Markdown: https://insights.sbomify.com/CVE-2026-93421/index.md)","id":"CVE-2026-93421","markdown":"https://insights.sbomify.com/CVE-2026-93421/index.md","name":"CVE-2026-93421","record":{"aliases":["GHSA-g7f6-rxc4-qhph","PYSEC-2026-4105"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UI framework","requires_auth":"none","summary":"Attackers can inject ANSI escape sequences into logs via an unauthenticated endpoint, potentially misleading operators viewing terminal output.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"},{"id":"CWE-117","name":"Improper Output Neutralization for Logs"}],"description":"Mesop is a Python-based UI framework that allows users to build web applications. Prior to 1.3.4, the unauthenticated /__csp__ endpoint passes attacker-controlled document-uri, blocked-uri, and violated-directive values to the csp_report handler in mesop/server/static_file_serving.py, which prints them to standard output without neutralizing terminal control sequences. When an operator views the resulting logs in an ANSI-capable terminal, injected ANSI or VT100 sequences can clear or reposition the display, hide text, or present forged messages, reducing the integrity of monitoring and incident-response output. This issue is fixed in version 1.3.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint","id":"CVE-2026-93421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Dokploy: Authenticated OS Command Injection in patch.readRepoDirectories (repoPath) leads to RCE as root","id":"CVE-2026-93425"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"mesop","purl":null,"source":"GHSA-g7f6-rxc4-qhph"},{"ecosystem":"PyPI","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"mesop","purl":"pkg:pypi/mesop","source":"GHSA-g7f6-rxc4-qhph"},{"ecosystem":"PyPI","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"mesop","purl":"pkg:pypi/mesop","source":"PYSEC-2026-4105"}],"prev":{"headline":"Mailspring: Stored XSS in attachment quick preview (unsanitized Markdown/DOCX/XLSX conversion)","id":"CVE-2026-93405"},"products":["mesop"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["mesop-dev"]},"summary":"Attackers can inject ANSI escape sequences into logs via an unauthenticated endpoint, potentially misleading operators viewing terminal output.","url":"https://insights.sbomify.com/CVE-2026-93421/"}