# CVE-2026-93421: Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint

> Attackers can inject ANSI escape sequences into logs via an unauthenticated endpoint, potentially misleading operators viewing terminal output.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-g7f6-rxc4-qhph, PYSEC-2026-4105

## What is CVE-2026-93421?

CVE-2026-93421 is a medium-severity vulnerability in mesop-dev mesop, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mesop is a Python-based UI framework that allows users to build web applications. Prior to 1.3.4, the unauthenticated /__csp__ endpoint passes attacker-controlled document-uri, blocked-uri, and violated-directive values to the csp_report handler in mesop/server/static_file_serving.py, which prints them to standard output without neutralizing terminal control sequences. When an operator views the resulting logs in an ANSI-capable terminal, injected ANSI or VT100 sequences can clear or reposition the display, hide text, or present forged messages, reducing the integrity of monitoring and incident-response output. This issue is fixed in version 1.3.4.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2026-93421?

3 open source packages ship an affected version, including mesop.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mesop` | PyPI | All versions | 1.3.4 |
| `mesop` | PyPI | All versions | 1.3.4 |
| `mesop` | PyPI | All versions | 1.3.4 |

## How do I fix CVE-2026-93421?

Upgrade mesop to 1.3.4 or later.

## Is CVE-2026-93421 being exploited?

There is no known exploitation of CVE-2026-93421 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93421 and fix it if it is affected.

What it is: CVE-2026-93421 is a medium-severity vulnerability in mesop-dev mesop, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-93421 in the wild and no public exploit code.

Affected packages and fixed versions:
- mesop (PyPI): affected all versions; fixed in 1.3.4
- mesop (PyPI): affected all versions; fixed in 1.3.4
- mesop (PyPI): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93421/ (Markdown: https://insights.sbomify.com/CVE-2026-93421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93421
- OSV: https://osv.dev/vulnerability/CVE-2026-93421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93421/
Summaries are generated and may contain mistakes; the official description above is the record.
