# CVE-2026-93425: Dokploy: Authenticated OS Command Injection in patch.readRepoDirectories (repoPath) leads to RCE as root

> Authenticated users can inject shell commands via repoPath to execute arbitrary code as root, potentially compromising the host via Docker socket access.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-56g6-wjr4-5q7p

## What is CVE-2026-93425?

CVE-2026-93425 is a critical command injection vulnerability in dokploy, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dokploy is a free, self-hostable Platform as a Service (PaaS). Prior to 0.29.13, the patch.readRepoDirectories tRPC procedure passes the user-controlled repoPath value from apps/dokploy/server/api/routers/patch.ts into a shell command in packages/server/src/services/patch-repo.ts without safe argument quoting. An authenticated organization member with service:read permission can inject shell metacharacters into repoPath and execute arbitrary commands through child_process.exec as root in the Dokploy container. The supplied service identifier is used only to resolve the server and does not constrain repoPath. Because the standard deployment mounts /var/run/docker.sock, container-root command execution can be used to control Docker and compromise the host and its managed applications. This issue is fixed in version 0.29.13.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-93425?


## How do I fix CVE-2026-93425?

No fix has been published for CVE-2026-93425 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-93425 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93425 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93425 and fix it if it is affected.

What it is: CVE-2026-93425 is a critical command injection vulnerability in dokploy, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-93425 exists.

Affected product: dokploy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93425/ (Markdown: https://insights.sbomify.com/CVE-2026-93425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93425
- OSV: https://osv.dev/vulnerability/CVE-2026-93425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93425/
Summaries are generated and may contain mistakes; the official description above is the record.
