CVE-2026-93446 Apache Tomcat: Possible TLS 1.3 connection failures
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-93446?
CVE-2026-93446 is a high-severity vulnerability in Apache Tomcat, published on 20 Oct 2026.
Official description
Incomplete cleanup vulnerability in Apache Tomcat could cause TLS 1.3 connections to fail intermittently.
This issue affects Apache Tomcat: from 11.0.0-M21 through 11.0.26, from 10.1.25 through 10.1.60, from 9.0.90 through 9.0.122.
Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
Weakness: CWE-459
Which versions are affected by CVE-2026-93446?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 9.0.90 | 9.0.123, 10.1.61, 11.0.27 |
How do I fix CVE-2026-93446?
Upgrade tomcat to a fixed version for your release line: 9.0.123, 10.1.61 or 11.0.27.
Is CVE-2026-93446 being exploited?
There is no known exploitation of CVE-2026-93446 in the wild and no public exploit code.
Sources
Also known as BIT-tomcat-2026-93446, DEBIAN-CVE-2026-93446, GHSA-2w6h-6wr9-m5r8, UBUNTU-CVE-2026-93446.