{"answers":{"affected":"1 open source package ship an affected version, including tomcat.","exploited":"There is no known exploitation of CVE-2026-93446 in the wild and no public exploit code.","fix":"Upgrade tomcat to a fixed version for your release line: 9.0.123, 10.1.61 or 11.0.27.","what":"CVE-2026-93446 is a high-severity vulnerability in Apache Tomcat, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-93446 and fix it if it is affected.\n\nWhat it is: CVE-2026-93446 is a high-severity vulnerability in Apache Tomcat, published on 20 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-93446 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tomcat (Bitnami): affected from 9.0.90; fixed in 9.0.123, 10.1.61, 11.0.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-93446/ (Markdown: https://insights.sbomify.com/CVE-2026-93446/index.md)","id":"CVE-2026-93446","markdown":"https://insights.sbomify.com/CVE-2026-93446/index.md","name":"CVE-2026-93446","record":{"aliases":["BIT-tomcat-2026-93446","DEBIAN-CVE-2026-93446","GHSA-2w6h-6wr9-m5r8","UBUNTU-CVE-2026-93446"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"}],"description":"Incomplete cleanup vulnerability in Apache Tomcat could cause TLS 1.3 connections to fail intermittently.\n\nThis issue affects Apache Tomcat: from 11.0.0-M21 through 11.0.26, from 10.1.25 through 10.1.60, from 9.0.90 through 9.0.122.\n\nUsers are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tomcat: Possible TLS 1.3 connection failures","id":"CVE-2026-93446","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Langflow OSS is affected by multiple vulnerabilities","id":"CVE-2026-93447"},"packages":[{"ecosystem":"Bitnami","fixed":["9.0.123","10.1.61","11.0.27"],"introduced":["9.0.90","10.1.25","11.0.0"],"last_affected":[],"package":"tomcat","purl":"pkg:bitnami/tomcat","source":"BIT-tomcat-2026-93446"}],"prev":{"headline":"Langflow OSS is affected by multiple vulnerabilities","id":"CVE-2026-93445"},"products":["Apache Tomcat"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-93446/"}