# CVE-2026-93451: snappy-java through 1.1.10.8 Buffer Overflow via typed uncompress methods

> Attackers can trigger a buffer overflow in snappy-java via crafted compressed input, leading to heap corruption and potential code execution.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-MH58992, CLEANSTART-2026-OU24429, CLEANSTART-2026-WK92445, CLEANSTART-2026-XV24797, ECHO-9610-b82b-faac, GHSA-gwq9-9ffj-mvrv, UBUNTU-CVE-2026-93451

## What is CVE-2026-93451?

CVE-2026-93451 is a medium-severity memory corruption vulnerability in xerial snappy-java, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

snappy-java through 1.1.10.8 contains a buffer overflow vulnerability in typed Snappy.uncompress*Array methods that allocate output arrays by dividing uncompressed length by element size but pass the undivided length to native code. Attackers controlling compressed input can cause misaligned length values to write past array bounds with attacker-controlled bytes, corrupting heap memory.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-93451?

2 open source packages ship an affected version, including org.xerial.snappy:snappy-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |

## How do I fix CVE-2026-93451?

Upgrade org.xerial.snappy:snappy-java to 1.1.10.9 or later.

## Is CVE-2026-93451 being exploited?

There is no known exploitation of CVE-2026-93451 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-93451 and fix it if it is affected.

What it is: CVE-2026-93451 is a medium-severity memory corruption vulnerability in xerial snappy-java, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-93451 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-93451/ (Markdown: https://insights.sbomify.com/CVE-2026-93451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-93451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-93451
- OSV: https://osv.dev/vulnerability/CVE-2026-93451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-93451/
Summaries are generated and may contain mistakes; the official description above is the record.
