CVE-2026-93577 Integer Overflow or Wraparound in GitLab

Critical 9.9 Published Updated

An authenticated user can execute arbitrary code on the GitLab server via an integer overflow in CI/CD regular expression compilation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-93577?

CVE-2026-93577 is a critical vulnerability in Gitlab Gitlab, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.

Weakness: CWE-190

Which versions are affected by CVE-2026-93577?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 19.2.019.2.7, 19.3.3, 19.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-93577?

Upgrade gitlab to a fixed version for your release line: 19.2.7, 19.3.3 or 19.4.1.

Is CVE-2026-93577 being exploited?

There is no known exploitation of CVE-2026-93577 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as ALPINE-CVE-2026-93577, BELL-CVE-2026-93577, BIT-gitlab-2026-93577, DEBIAN-CVE-2026-93577, GHSA-wqwg-376r-c226, MINI-6fjr-jmr6-v3ff and 12 more.

Is CVE-2026-93577 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free